Jump to content
Join the Unexplained Mysteries community today! It's free and setting up an account only takes a moment.
- Sign In or Create Account -
Sign in to follow this  
Saru

'Server Busy' Message

30 posts in this topic

Recommended Posts

Saru

A common problem with certain Linux machines relating to iowait which causes abnormally high server loads has recently started to effect our server also, the high load seems to occur at around the same time every day, but fortunately only lasts for a few minutes when it does happen.

When the server load exceeds 10, a mechanism on the forum designed to reduce the load kicks in, displaying a 'Server Busy' message when anyone tries to access it until the load drops below 10 again. If you receive this message, try accessing the board again in a few minutes.

My apologies for any inconvenience these issues may cause.

Share this post


Link to post
Share on other sites
Daughter of the Nine Moons

Wondered about that, as it wasn't the first time I got that message.

Share this post


Link to post
Share on other sites
Magikman

I noticed the problem for the first time last week. Lasted over 30 minutes, was around 3pm Central Time. Thing is, the 'server load' was only showing around a 3.0 or a little higher each time I tried to refresh.

Share this post


Link to post
Share on other sites
Daughter of the Nine Moons

For me it was happening about 1:30-2 EST

Share this post


Link to post
Share on other sites
MichaelS

For me, it happend on and off all day... and I'm not even on a Linux machine... maybe it's because this computer is Canadian Military issue...

Share this post


Link to post
Share on other sites
Saru

and I'm not even on a Linux machine

When i say 'linux machine' i mean the server on which this site is hosted is a linux machine, the problem doesn't have anything to do with the Operating System that you're running on your computer.

Thing is, the 'server load' was only showing around a 3.0 or a little higher each time I tried to refresh.

That sounds like you might have been looking at a cached copy of the page, the 'server busy' message should only come up when the load is exceeding 10.

Share this post


Link to post
Share on other sites
thebarman

I just got it now, lasted only a minute. Time now is 17:20 BST

Share this post


Link to post
Share on other sites
Daughter of the Nine Moons

I got it too 12:17 EST. The server load went to 16+

Share this post


Link to post
Share on other sites
Saru

This is actually quite helpful, could anyone who experiences this problem let me know what time it occured by posting here - if it does turn out to be within the same hour or so every day, it will be a lot easier to diagnose whats causing it.

Thanks thumbsup.gif

Share this post


Link to post
Share on other sites
Daughter of the Nine Moons

In that case, there was another server load problem @ 12:38 EST went to 11+

It lasted less than a minute original.gif

Share this post


Link to post
Share on other sites
BurnSide

I just had the same problem, around 12:40PM EST same as Dot.

Share this post


Link to post
Share on other sites
Janiel

hmm, ive never had any trouble...

Share this post


Link to post
Share on other sites
Daughter of the Nine Moons

while I was trying to log back on

Starting at 12:16 EST to 12:20EST

[ Script Execution time: 1.6006 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 10.75 ]

[ Script Execution time: 0.3051 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 12.06 ]

[ Script Execution time: 2.5709 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 11.10 ]

[ Script Execution time: 0.0228 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 11.56 ]

[ Script Execution time: 0.0075 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 11.29 ]

[ Script Execution time: 0.0099 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 11.41 ]

[ Script Execution time: 0.0073 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 12.97 ]

[ Script Execution time: 0.0170 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 13.79 ]

[ Script Execution time: 0.0170 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 13.79 ]

[ Script Execution time: 0.0065 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 16.26 ]

[ Script Execution time: 1.2856 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 17.99 ]

[ Script Execution time: 0.0065 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 18.01 ]

[ Script Execution time: 0.0069 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 16.31 ]

[ Script Execution time: 0.0066 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 14.54 ]

[ Script Execution time: 2.6653 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 13.61 ]

[ Script Execution time: 0.0061 ] [ 2 queries used ] [ GZIP Enabled ] [ Server Load: 11.92 ]

Share this post


Link to post
Share on other sites
AliceCoopersGirl

Mine was between 5.05pm and 5.20pm BST.

Hope thats helping SaRuMaN.

Share this post


Link to post
Share on other sites
BurnSide

I got mine the same as dot.

Share this post


Link to post
Share on other sites
Saru

I've modified the forum server load cut out to 15 instead of 10, so it shouldn't do it as often now. You may find that the site will go a bit slower during a period of high server load however, at least until i find a way to resolve the Iowait issues so that it doesn't do this at all.

Share this post


Link to post
Share on other sites
Daughter of the Nine Moons

Hey SaRu,

Is it still helpful for you to know when we are having server load issues?

If it is, starting at 3:29pm EST to 3:34pm EST this occured:

[ Script Execution time: 0.0072 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 17.31 ]

[ Script Execution time: 0.0075 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 18.88 ]

[ Script Execution time: 0.0073 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 19.91 ]

[ Script Execution time: 0.1685 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 21.60 ]

[ Script Execution time: 0.0122 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 22.08 ]

[ Script Execution time: 0.0128 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 22.28 ]

[ Script Execution time: 0.0081 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 22.76 ]

[ Script Execution time: 0.2225 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 23.78 ]

[ Script Execution time: 12.5298 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 27.52 ]

[ Script Execution time: 0.0072 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 31.74 ]

[ Script Execution time: 0.0276 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 26.31 ]

[ Script Execution time: 0.0074 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 23.65 ]

[ Script Execution time: 0.0067 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 21.48 ]

[ Script Execution time: 0.0071 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 19.79 ]

[ Script Execution time: 0.0080 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 18.67 ]

[ Script Execution time: 0.0072 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 18.05 ]

[ Script Execution time: 0.0070 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 17.20 ]

[ Script Execution time: 0.0073 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 16.55 ]

[ Script Execution time: 0.7824 ] [ 3 queries used ] [ GZIP Disabled ] [ Server Load: 16.14 ]

Dot original.gif

Share this post


Link to post
Share on other sites
Saru

Is it still helpful for you to know when we are having server load issues?

Probably not any more, there's still no real clue as to the cause of the load spikes apart from a potential flaw in the Linux Kernel. I've rebooted the server to see if that helps it, might prevent any more happening for a few days. The number of processes seems to be back to normal again for the moment.

Share this post


Link to post
Share on other sites
Daughter of the Nine Moons

Ok. If you need this info in the future, let us now.

Dot original.gif

Share this post


Link to post
Share on other sites
Saru

Ok thanks Dot thumbsup.gif

Share this post


Link to post
Share on other sites
BurnSide

I just had 'server busy' for 5 mins at 3:45 EST.

Share this post


Link to post
Share on other sites
ames2787

me too at 8.45 GMT original.gif

Share this post


Link to post
Share on other sites
BurnSide

And another one for 10 mins from 9:07pm EST.

Share this post


Link to post
Share on other sites
AliceCoopersGirl

Are we still having problems with this?

I have not for a while now,if that helps. thumbsup.gif

Share this post


Link to post
Share on other sites
Saru

It actually looks as though the forum upgrade has fixed the server load issues - the load has stayed at reasonable levels since the update, and has not gone any higher than what would be considered normal.

The new version of Invision Board seems to use less queries and is more efficient than the old one, plus the database optimization performed during the upgrade process would have also helped.

I think the problem has been pretty much resolved. original.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.