Jump to content
Join the Unexplained Mysteries community today! It's free and setting up an account only takes a moment.
- Sign In or Create Account -

Block a specific driver update on Win10?


acute
 Share

Recommended Posts

Hello, folks.  Yes, it's Windows ******g 10 again!

When it checks for updates on my laptop, it tries (every time!) to install an obsolete Device Driver, and I can't find out how to stop it.

It displays a message saying  "A current driver on your PC may be better than the one we're trying to install. We'll keep trying to install."

 

Uh? :blink:

Link to comment
Share on other sites

 
39 minutes ago, acute said:

, it tries (every time!) to install an obsolete Device Driver, and I can't find out how to stop it.

One option is that the device is already running a non-standard driver, can you name the device?

Link to comment
Share on other sites

Turn off automatic updates.

You can then check and pick the updates you want. It is a hassle, and you will never be sure what to pick, but that's the only way.

Link to comment
Share on other sites

Gotta roll back the driver that is having problems first, then disable auto update. 

~

Link to comment
Share on other sites

I have this, well similar. Every time I use my laptop, within 5 hours (sometimes it pops up as soon as I log into my user, and other times I log off to do something and when I come back then it pops up) a blue screen pops up saying how they want to update my laptop to a Windows 10, because my current version won't be supported or something, I can't remember word for word. I have only two choices when it pops up.

1. To click the "not now" button.

2. To click the "Learn More" button.

And its so annoying, its literally been doing that since December of 2017.

 

I assume its somewhat similar, but anyways I don't know how to stop either without updating.

Edited by Chronus
Link to comment
Share on other sites

9 hours ago, toast said:

One option is that the device is already running a non-standard driver, can you name the device?

It's a graphics driver.

The driver I'm using is the right one, and the latest one, and I don't have any problems with it.

I just need to stop Windows Update trying to install something else.

Link to comment
Share on other sites

9 hours ago, zep73 said:

Turn off automatic updates.

You can then check and pick the updates you want. It is a hassle, and you will never be sure what to pick, but that's the only way.

 

9 hours ago, RAyMO said:

did you manually check for updates

 

Checking for updates manually or automatically makes no difference.

The update is there, waiting to be installed, before I start an Update check.

Link to comment
Share on other sites

9 hours ago, third_eye said:

Gotta roll back the driver that is having problems first, then disable auto update. 

I'm happy with the driver I'm using.

No problems with it.

  • Like 1
Link to comment
Share on other sites

1 hour ago, acute said:

I'm happy with the driver I'm using.

No problems with it.

But you're no longer using the driver you're using, it's partially updated, that's why you have to "roll back" to your previous driver "that works"

At least that's what I understand from previous version of auto updates...

Best refer to the hardware tech support site, sometimes it's not this driver that is the problem, but "dependants" that has to work with the updated hardware... 

 

~

Link to comment
Share on other sites

15 minutes ago, third_eye said:

But you're no longer using the driver you're using, it's partially updated, that's why you have to "roll back" to your previous driver "that works"

I re-installed the latest driver from the Asus website yesterday, to make sure I had the best one.

Also..... there's nothing to 'roll back' to, because I had my HDD changed a few weeks ago.

  • Thanks 1
Link to comment
Share on other sites

27 minutes ago, acute said:

Also..... there's nothing to 'roll back' to, because I had my HDD changed a few weeks ago.

Maybe that's the reason why the update is having problems... 

~

Link to comment
Share on other sites

 
3 hours ago, acute said:

The update is there, waiting to be installed, before I start an Update check.

There's a little box next to it, that you can uncheck, and thereby ignore it.

Link to comment
Share on other sites

6 hours ago, zep73 said:

There's a little box next to it, that you can uncheck, and thereby ignore it.

I hope you can see this:

IMG_20201108_201307157(2cxAVKKTL6c).thumb.jpg.888b9a4a47ded8d0c19a5bfcb533cd4b.jpg

This is how it looks when I restart the laptop, then it tries to install the driver, then gives this error message again.

I don't click on 'Retry' --- It retries automatically.

 

Edited by acute
Link to comment
Share on other sites

@acute I've only had win10 since last December, so I'm not very experienced in how to solve issues yet. I just assumed Update would be like win7. Sorry.

  • Like 1
Link to comment
Share on other sites

I appreciate all suggestions.

:tu:

 

Edited by acute
  • Like 1
Link to comment
Share on other sites

None of the tips in the above article made any difference, so I've paused the updates for 7 days, and I will repeat (ad infinitum) if necessary.

  • Thanks 1
Link to comment
Share on other sites

You can choose which win 10  updates you want to down load or  just uninstall them 

1.Go to settings and updates and security. 2 click on show update history 3 click on uninstall updates and uninstall the driver.

How to disable all updates.

1.settings,2 click on update and security, 3. Click on win update. 4. Click on advanced options button under "pause updates" use the pause until drop down menu select when to resume updates 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.